Keyboard Issue on Linux OS

Discussion specifically on the IdeaPad S10-3 amd S10-3t

Moderator: Moderators

Forum rules
Please discuss topics related specifically for the IdeaPad S10-3 and S10-3t.

Keyboard Issue on Linux OS

Postby krittis » Fri Aug 27, 2010 6:34 am

I have a small problem with my Lenovo s10-3c when running *any* Linux operating system (I have tried Fedora, Fluppy, Ubuntu, and Mandriva so far, along with multiple versions). For any of the distros, my keyboard does not respond in any way. Even when I press CAPS LOCK, the light does not appear. Booting in the command line mode also does not work as I cannot type anything.

If anyone has any information as to why my keyboard is incompatible with Linux, and if there is a way to fix it, then please let me know. However, since I haven't really been able to get Linux to work yet, please give me detailed instructions if I need to do any sort of "fancy" Linux stuff!

Thanks a lot for your assistance!
krittis
New User
 
Posts: 1
Joined: Fri Aug 27, 2010 6:29 am
Color and Model: Black Lenovo S10-3C
OS(s) installed: Windows 7 and Ubuntu 10.04

Advertisement

Re: Keyboard Issue on Linux OS

Postby tgb » Sun Sep 26, 2010 9:40 am

I am not sure if this will help or not since I am using an S10-3 and not a 3c. I assume you are installing the netbook versions of Linux and not the desktop versions? I tried installing Ubuntu 10.04 i-386 desktop version and had problems somewhat similar to yours. I removed it and installed the Ubuntu 10.04 i-386 netbook version and it has worked perfectly. I did the install from a USB flash drive with the full ISO file (not the Live CD version).

Though this is somewhat irrelevant to your particular question, but to let you know about the S10-3 compatibility with Windows and Linux: I am running the Ubuntu netbook Linux as a dual boot with Win 7 Pro 32-bit which I installed in place of the Starter edition. I also replaced the 1 GB RAM with 2 GB before upgrading the Win 7. Both of these OS are performing well on the S10-3 and I have had no problems (other than the usual MS junk).
tgb
New User
 
Posts: 2
Joined: Sun Sep 26, 2010 9:08 am
Color and Model: Black S10-3
OS(s) installed: Win 7 Pro + Ubuntu 10.04 netbook

Re: Keyboard Issue on Linux OS

Postby minahold » Thu Sep 30, 2010 9:37 am

I have the same problem. I have an s10-3c. I loaded puppy 5.11 and tried other puppy versions. the keyboard does not function. Help!
minahold
New User
 
Posts: 1
Joined: Thu Sep 30, 2010 9:32 am
Color and Model: s10-3c
OS(s) installed: windows 7 starter

Re: Keyboard Issue on Linux OS

Postby lanser » Fri Oct 01, 2010 5:47 pm

Minahold. I am running Mint 9 Debian on my S10-3. No issues apart from the brightness keys not working.
Fixed this via creating a couple of launchers on the desktop to manually set the brightness.
I expect the issue will be resolved when distros ship with 2.6.36 or later.

Lanser
lanser
New User
 
Posts: 1
Joined: Fri Oct 01, 2010 5:33 pm
Color and Model: S10-3
OS(s) installed: Mint 9 Debian

Re: Keyboard Issue on Linux OS

Postby bond1977 » Sun Oct 03, 2010 5:05 pm

"noapic acpi=off" is the answer to this problem for lenovo s10-3c

1. at the GRUB Menu put your cursor on the line that will load your ubuntu OS (not the recovery mode)
2. then hit "e" to edit the line
3. look for the word quiet splash and put your cursor after the word splash
4. then type "noapic acpi=off" (without the quotes) after the word splash
5. then pres "CTRL X"
6. then cross your fingers, hehehe...

hope this will help your problem coz to me it really solve my problem.
this is an old solution (2007), i dont know why linux kernel developers were not able to solve this bug.
bond1977
New User
 
Posts: 1
Joined: Sun Oct 03, 2010 11:38 am
Color and Model: black lenovo s10-3c
OS(s) installed: both unbuntu rc 10.10 and windows 7 starter

Re: Keyboard Issue on Linux OS

Postby zurggie » Thu Oct 21, 2010 9:18 pm

Just install Ubuntu 10.10 Maverick on s10-3c... The solution above work but not permanent. You can only use keyboard in that session. After restart, you have to type the command again in GRUB menu. Also with "noapic acpi=off", I cannot shutdown my s10-3c properly. Have to use the power button to shutdown.
zurggie
New User
 
Posts: 1
Joined: Thu Oct 21, 2010 5:14 pm
Color and Model: black idepad s10-3c
OS(s) installed: ubuntu

Re: Keyboard Issue on Linux OS

Postby Zaephor » Wed Dec 01, 2010 2:25 am

Not sure if this would work for everyone here, since I'm new to the party and only working with an S10-3.
I hadn't seen anything of people using the noapic and apci=off until this thread, but since Ubuntu 10.10 is having boot halting issues related to some apci stuff thought maybe the kernel flag I found elsewhere might help out the S10-3c users.
To get things running I've been adding "intel_idle.max_cstate=0" to everything. And to get it to stick in grub it just needs to be added in the /etc/default/grub file, then run sudo update-grub
Zaephor
Beginner
 
Posts: 8
Joined: Wed Dec 01, 2010 1:24 am
Color and Model: 2x S10-3 Black
OS(s) installed: NetbookA - Ubuntu 10.10 NetbookB - Win7 Starter

Re: Keyboard Issue on Linux OS

Postby psychedelic » Sun Jun 12, 2011 9:28 am

Dear Zaephor,
the only issue with your solution is that the grub file is not editable. (/etc/default/grub).
"You are not the owner, so you cannot change these permissions." is the message displayed.
But I AM the owner. So , I don't know what to do.
Please, any help is appreciated.
psychedelic
New User
 
Posts: 2
Joined: Sun Jun 12, 2011 8:57 am
Color and Model: s10-3c
OS(s) installed: ubutu 11.04

Re: Keyboard Issue on Linux OS

Postby EagleClaw » Tue Jun 14, 2011 11:36 am

psychedelic;

You are not the owner. Root is the owner and as such you need to execute the command as superuser (root).
To do that, you type "sudo vim /etc/default/grub", assuming you use vim as your text editor. You can use any text editor you like.
When it asks for the root password, in case you didn't change it after install, type in your regular user password.
I hope it helps.
EagleClaw
New User
 
Posts: 2
Joined: Tue Jun 14, 2011 11:31 am
Color and Model: S10-3 Black
OS(s) installed: Kubuntu 11.04

Re: Keyboard Issue on Linux OS

Postby psychedelic » Tue Jun 14, 2011 11:13 pm

Dear EagleClaw,
Thankyou for your help.
This is what i did:
i tried "sudo gedit /etc/default/grub" and added "noapic accpi=off" after quiet splash. So, the line looks like: "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic acpi=off"
Then i saved the grub file, and ran "sudo update-grub" it did come up with some lines like:
psychedelic@Lenovo-S10-3c:~$ sudo update-grub
[sudo] password for psychedelic:
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.38-8-generic
Found GRUB 2: /boot/grub/core.img
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

and then when it was done i restarted my system ..But again the keyboard refuses to work. So, I had to press E on my keyboard to add "noapic acpi=off" after the "splash" word for the keyboard to work.
Please, i'd appreciate it if you can correct my mistake and point me in the correct direction once more.
psychedelic
New User
 
Posts: 2
Joined: Sun Jun 12, 2011 8:57 am
Color and Model: s10-3c
OS(s) installed: ubutu 11.04

Next

Return to IdeaPad S10-3 and S10-3t Discussion

Who is online

Users browsing this forum: No registered users and 0 guests

cron